summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2002-10-04 18:31:54 +0000
committerHavoc Pennington <hp@src.gnome.org>2002-10-04 18:31:54 +0000
commit9de7b59e93787a8d4562f4f2042b8da685033a66 (patch)
tree28f03f6d5169cce9df86c45e8ccdd560b7b61c16 /configure.in
parent038814990423d88ac4638acfbac2547990f029d0 (diff)
downloadmetacity-9de7b59e93787a8d4562f4f2042b8da685033a66.tar.gz
do XRRUpdateConfiguration() if we have RandR extension, else poke in
2002-10-04 Havoc Pennington <hp@redhat.com> * src/display.c (event_callback): do XRRUpdateConfiguration() if we have RandR extension, else poke in Xlib's screen struct to update the screen size. * configure.in: fix a bogus overwrite of cppflags, add a check for RandR extension
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fb875132..9c6168be 100644
--- a/configure.in
+++ b/configure.in
@@ -160,7 +160,16 @@ if test "$found_shape" = "true"; then
AC_DEFINE(HAVE_SHAPE)
fi
-CPPFLAGS="$save_CPPFLAGS"
+RANDR_LIBS=
+found_randr=false
+AC_CHECK_LIB(Xrandr, XRRUpdateConfiguration,
+ [AC_CHECK_HEADERS(X11/extensions/Xrandr.h,
+ RANDR_LIBS=-lXrandr found_randr=true)],
+ , -lXrender $ALL_X_LIBS)
+
+if test "$found_randr" = "true"; then
+ AC_DEFINE(HAVE_RANDR)
+fi
METACITY_LIBS="$SHAPE_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_LIBS"
METACITY_MESSAGE_LIBS="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_MESSAGE_LIBS"