summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBill Haneman <billh@src.gnome.org>2003-01-28 15:07:43 +0000
committerBill Haneman <billh@src.gnome.org>2003-01-28 15:07:43 +0000
commitb4243647105667b0d346f991c647d8e57bfed033 (patch)
tree82255a87796fb3a2ea3020bede91ca62b0da5fb5 /configure.in
parent4fb05e54ab1616d5842dba31ff1d9832cce704be (diff)
downloadmetacity-b4243647105667b0d346f991c647d8e57bfed033.tar.gz
Reinstated visual-bell patch, fix for bug 99886.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8988650d..54b2c6c9 100644
--- a/configure.in
+++ b/configure.in
@@ -235,6 +235,17 @@ if test "x$found_shape" = "xyes"; then
AC_DEFINE(HAVE_SHAPE, , [Have the shape extension library])
fi
+found_xkb=no
+AC_CHECK_LIB(X11, XkbQueryExtension,
+ [AC_CHECK_HEADER(X11/XKBlib.h,
+ found_xkb=yes)],
+ , $ALL_X_LIBS)
+
+if test "x$found_xkb" = "xyes"; then
+ AC_DEFINE(HAVE_XKB, , [Have keyboard extension library])
+fi
+
+
RANDR_LIBS=
found_randr=no
AC_CHECK_LIB(Xrandr, XRRUpdateConfiguration,