summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas James Alexander Thurman <tthurman@src.gnome.org>2009-03-06 22:51:02 +0000
committerThomas James Alexander Thurman <tthurman@src.gnome.org>2009-03-06 22:51:02 +0000
commitab6aa5463ffdd5cfaf729eb1f5407be749ba1090 (patch)
tree6919745dae59f7a7a0bfcaae5e51be4241fa77ee /configure.in
parent42387bff6ffab4e741cdc69b46cdf8308a690a22 (diff)
downloadmetacity-ab6aa5463ffdd5cfaf729eb1f5407be749ba1090.tar.gz
add optional dependency on gtop. Include "(as username)" in the titlebar
* configure.in: add optional dependency on gtop. * src/core/window-props.c: Include "(as username)" in the titlebar if a window is running as another user. * src/core/window.c: check for PID before name, since the rendering of the name can now depend on the PID. Closes #549389. svn path=/trunk/; revision=4181
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d53b56db..3884d897 100644
--- a/configure.in
+++ b/configure.in
@@ -284,6 +284,20 @@ if test x$have_xcursor = xyes; then
AC_DEFINE(HAVE_XCURSOR, , [Building with Xcursor support])
fi
+AC_MSG_CHECKING([libgtop])
+if $PKG_CONFIG libgtop-2.0; then
+ have_gtop=yes
+ else
+ have_gtop=no
+ fi
+ AC_MSG_RESULT($have_gtop)
+
+if test x$have_gtop = xyes; then
+ echo "Building with libgtop"
+ METACITY_PC_MODULES="$METACITY_PC_MODULES libgtop-2.0"
+ AC_DEFINE(HAVE_GTOP, , [Building with libgtop])
+fi
+
PKG_CHECK_MODULES(METACITY, $METACITY_PC_MODULES)
AC_PATH_XTRA