summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlberts Muktupāvels <alberts.muktupavels@gmail.com>2015-01-07 13:50:58 +0200
committerAlberts Muktupāvels <alberts.muktupavels@gmail.com>2015-01-07 13:50:58 +0200
commitd982d0a50f5941944e60cd519a0ba935733f4b2c (patch)
treedf94a59918ec09d555ce848e465fdf88b3ebbb5a /src/Makefile.am
parent03e8e63d6accd26f47025ba23d295de910f9f989 (diff)
downloadmetacity-d982d0a50f5941944e60cd519a0ba935733f4b2c.tar.gz
build everything as library
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am45
1 files changed, 17 insertions, 28 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 28532948..d08667b9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,6 +5,13 @@ SUBDIRS = tools themes
AM_CPPFLAGS=-I$(srcdir)/include -DMETACITY_LIBEXECDIR=\"$(libexecdir)\" -DHOST_ALIAS=\"@HOST_ALIAS@\" -DMETACITY_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\" -DMETACITY_PKGDATADIR=\"$(pkgdatadir)\" -DMETACITY_DATADIR=\"$(datadir)\" -DG_LOG_DOMAIN=\"metacity\" -DSN_API_NOT_YET_FROZEN=1 @METACITY_CFLAGS@
metacity_SOURCES= \
+ core/main.c \
+ include/main.h
+
+# by setting libmetacity_private_la_CFLAGS, the files shared with
+# metacity proper will be compiled with different names.
+libmetacity_private_la_CFLAGS =
+libmetacity_private_la_SOURCES= \
core/async-getprop.c \
core/async-getprop.h \
core/atomnames.h \
@@ -87,16 +94,18 @@ metacity_SOURCES= \
ui/menu.h \
ui/metaaccellabel.c \
ui/metaaccellabel.h \
+ ui/preview-widget.c \
+ ui/preview-widget.h \
ui/resizepopup.c \
include/resizepopup.h \
ui/tabpopup.c \
- include/tabpopup.h \
- ui/select-image.c \
- ui/select-image.h \
- ui/select-workspace.c \
- ui/select-workspace.h \
- ui/tile-preview.c \
- include/tile-preview.h \
+ include/tabpopup.h \
+ ui/select-image.c \
+ ui/select-image.h \
+ ui/select-workspace.c \
+ ui/select-workspace.h \
+ ui/tile-preview.c \
+ include/tile-preview.h \
ui/theme-parser.c \
ui/theme-parser.h \
ui/theme.c \
@@ -104,25 +113,6 @@ metacity_SOURCES= \
ui/ui.c \
include/all-keybindings.h
-# by setting libmetacity_private_la_CFLAGS, the files shared with
-# metacity proper will be compiled with different names.
-libmetacity_private_la_CFLAGS =
-libmetacity_private_la_SOURCES= \
- core/boxes.c \
- include/boxes.h \
- ui/gradient.c \
- ui/gradient.h \
- core/util.c \
- include/util.h \
- core/common.c \
- include/common.h \
- ui/preview-widget.c \
- ui/preview-widget.h \
- ui/theme-parser.c \
- ui/theme-parser.h \
- ui/theme.c \
- ui/theme.h
-
libmetacity_private_la_LDFLAGS = -no-undefined -version-info 2:0:0
libmetacity_private_la_LIBADD = @METACITY_LIBS@
@@ -149,8 +139,7 @@ convert_DATA = metacity-schemas.convert
bin_PROGRAMS=metacity metacity-theme-viewer
-EFENCE=
-metacity_LDADD=@METACITY_LIBS@ $(EFENCE)
+metacity_LDADD=@METACITY_LIBS@ libmetacity-private.la
metacity_theme_viewer_LDADD= @METACITY_LIBS@ libmetacity-private.la
testboxes_SOURCES=include/util.h core/util.c include/boxes.h core/boxes.c core/testboxes.c