summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@pobox.com>2002-01-28 02:09:12 +0000
committerHavoc Pennington <hp@src.gnome.org>2002-01-28 02:09:12 +0000
commit8ddeb4f953148473978443f94e6cf14e2d078f1e (patch)
tree64ca1ae2994be237988171819e6f17bcc26c62a6 /src/Makefile.am
parent33dd196cba189d17ab67cdf6cb3aed702a82e60c (diff)
downloadmetacity-8ddeb4f953148473978443f94e6cf14e2d078f1e.tar.gz
move in here so util.c doesn't require display.[hc]
2002-01-27 Havoc Pennington <hp@pobox.com> * src/display.c (meta_set_syncing): move in here so util.c doesn't require display.[hc] * src/theme.h, src/theme.c: implement coordinate expression parser, write MetaShapeSpec declaration * src/util.c (meta_exit): move in here so we can link to util.c with a different main() * src/theme.h: rename the MetaWindow* enums to MetaFrame*
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 81f25434..8391041a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -55,9 +55,19 @@ metacity_SOURCES= \
xprops.c \
xprops.h
-bin_PROGRAMS=metacity
+metacity_theme_viewer_SOURCES= \
+ gradient.c \
+ gradient.h \
+ theme.c \
+ theme.h \
+ theme-viewer.c \
+ util.c \
+ util.h
+
+bin_PROGRAMS=metacity metacity-theme-viewer
metacity_LDADD= @METACITY_LIBS@
+metacity_theme_viewer_LDADD= @METACITY_LIBS@
testgradient_SOURCES=gradient.h gradient.c testgradient.c