summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@jamesh.id.au>2004-11-10 07:59:38 +0000
committerJames Henstridge <jamesh@src.gnome.org>2004-11-10 07:59:38 +0000
commitbc9e517842177250ffd708da9e89484eab89c842 (patch)
tree9387022c50249419f0c4e5ae485686a94e817f56 /src/Makefile.am
parentf3743bc49409de3cf56463a6f57adc9f29623539 (diff)
downloadmetacity-bc9e517842177250ffd708da9e89484eab89c842.tar.gz
remove intltool stuff on distclean.
2004-11-10 James Henstridge <james@jamesh.id.au> * Makefile.am (DISTCLEANFILES): remove intltool stuff on distclean. * src/themes/Makefile.am (uninstall-local): add uninstall rule. * src/Makefile.am (libmetacity_private_la_CFLAGS): set this variable so that the files shared with metacity get compiled with different names. * configure.in: use more modern macros in some places, and make sure that $ACLOCAL_AMFLAGS is set so that rebuilds work better. * autogen.sh (conf_flags): use newer automake.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 391a79d3..5d3ffeb4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,6 +90,9 @@ metacity_SOURCES= \
xprops.h \
$(EGGFILES)
+# by setting libmetacity_private_la_CFLAGS, the files shared with
+# metacity proper will be compiled with different names.
+libmetacity_private_la_CFLAGS =
libmetacity_private_la_SOURCES= \
gradient.c \
gradient.h \
@@ -164,7 +167,7 @@ VARIABLES=default_icon_data $(srcdir)/default_icon.png \
stock_delete_data $(srcdir)/stock_delete.png
BUILT_SOURCES = inlinepixbufs.h
-CLEANFILES = inlinepixbufs.h
+CLEANFILES = inlinepixbufs.h metacity.desktop metacity.schemas
inlinepixbufs.h: $(IMAGES)
$(GDK_PIXBUF_CSOURCE) --raw --build-list $(VARIABLES) >$(srcdir)/inlinepixbufs.h