summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3bdf04f6..68aea07a 100644
--- a/configure.in
+++ b/configure.in
@@ -502,8 +502,15 @@ if test "x$GCC" = "xyes"; then
CFLAGS="$CFLAGS -Wall -ansi"
fi
-# Use gnome-doc-utils:
-GNOME_DOC_INIT([0.8.0])
+AC_ARG_ENABLE(themes-documentation,
+ AC_HELP_STRING([--disable-themes-documentation],
+ [disable building themes documentation on system where yelp-tools is unavailable]),,
+ enable_themes_documentation=yes)
+AM_CONDITIONAL(BUILD_THEMES_DOCS, test "$enable_themes_documentation" = "yes")
+
+if test x$enable_themes_documentation = xyes; then
+ YELP_HELP_INIT
+fi
AC_CONFIG_FILES([
Makefile