summaryrefslogtreecommitdiff
path: root/web/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'web/CMakeLists.txt')
-rw-r--r--web/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/web/CMakeLists.txt b/web/CMakeLists.txt
index a74ccf83..6224e812 100644
--- a/web/CMakeLists.txt
+++ b/web/CMakeLists.txt
@@ -15,11 +15,13 @@ foreach(UNIT_SRC ${EXTENSIONS})
include(ValaPrecompile)
vala_precompile(UNIT_SRC_C ${UNIT}
${UNIT_SRC}
+ ${CMAKE_SOURCE_DIR}/core/database.vala
+ ${CMAKE_SOURCE_DIR}/core/history.vala
${CMAKE_SOURCE_DIR}/core/loggable.vala
${CMAKE_SOURCE_DIR}/core/plugins.vala
${CMAKE_SOURCE_DIR}/core/settings.vala
PACKAGES
- libsoup-2.4 libpeas-1.0
+ libsoup-2.4 libpeas-1.0 sqlite3
OPTIONS
${VALAFLAGS}
CUSTOM_VAPIS