summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Dywan <christian@twotoasts.de>2015-03-22 17:59:59 +0100
committerChristian Dywan <christian@twotoasts.de>2015-03-22 17:59:59 +0100
commitec184fdff22f1e6ec70b4843fcb670cc47c6e0fa (patch)
tree0173e5d5c4b43e21962a0f52e99462ea260f41d8 /CMakeLists.txt
parent782b0d88ebe9d16c4923b94d7bc6de53f315d5a5 (diff)
downloadmidori-ec184fdff22f1e6ec70b4843fcb670cc47c6e0fa.tar.gz
Make GCR mandatory for all builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8fe6551..d0ff6202 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,17 +187,16 @@ if (USE_ZEITGEIST)
set(PKGS ${PKGS} zeitgeist-1.0)
endif()
-if (USE_GTK3)
- pkg_check_modules(GCR gcr-3>=2.32)
- if (GCR_VERSION)
- set(OPTS_INCLUDE_DIRS "${OPTS_INCLUDE_DIRS};${GCR_INCLUDE_DIRS}")
- set(OPTS_LIBRARIES "${OPTS_LIBRARIES};${GCR_LIBRARIES}")
- add_definitions("-DGCR_VERSION=\"${GCR_VERSION}\"")
- add_definitions("-DHAVE_GCR")
- set(VALAFLAGS ${VALAFLAGS} -D HAVE_GCR)
+if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.34.0")
+ if (USE_GTK3)
+ pkg_check_modules(GCR REQUIRED gcr-3>=2.32)
else ()
- add_definitions("-DGCR_VERSION=\"No\"")
+ pkg_check_modules(GCR REQUIRED gcr-base-3>=2.32)
endif ()
+ add_definitions("-DGCR_VERSION=\"${GCR_VERSION}\"")
+ add_definitions("-DHAVE_GCR")
+ set(OPTS_INCLUDE_DIRS ${OPTS_INCLUDE_DIRS} ${GCR_INCLUDE_DIRS})
+ set(OPTS_LIBRARIES ${OPTS_LIBRARIES} ${GCR_LIBRARIES})
else ()
add_definitions("-DGCR_VERSION=\"No\"")
endif ()