summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Dywan <christian.dywan@canonical.com>2013-09-01 19:10:49 +0200
committerChristian Dywan <christian.dywan@canonical.com>2013-09-01 19:10:49 +0200
commitd3ba8a8b629c5babf4a2954dba82e47f9747a949 (patch)
treeabae35da6c91e592fd261f9473a1b920915b469c /CMakeLists.txt
parent757d6e7b0e435332812f4a115ee8a6e5f05c1699 (diff)
downloadmidori-d3ba8a8b629c5babf4a2954dba82e47f9747a949.tar.gz
Always pass gio-2.0 as a dummy when only checking one package
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cba21067..7f85b88c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,7 +78,8 @@ if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.34.0")
set(VALAFLAGS ${VALAFLAGS} "-D;HAVE_LIBSOUP_2_34_0")
endif ()
-pkg_check_modules(OPTS libnotify)
+# Always pass >1 module, otherwise we get different variable names
+pkg_check_modules(OPTS gio-2.0 libnotify)
add_definitions("-DLIBNOTIFY_VERSION=\"${OPTS_libnotify_VERSION}\"")
set(PKGS ${PKGS} libnotify)
@@ -120,7 +121,9 @@ if (USE_GTK3)
add_definitions("-DWEBKIT_VERSION=\"${DEPS_GTK_webkitgtk-3.0_VERSION}\"")
set(PKGS ${PKGS} gtk+-3.0)
set(EXTRA_VAPIS ${EXTRA_VAPIS} "${CMAKE_SOURCE_DIR}/midori/webkitgtk-3.0.vapi")
+ # Always pass >1 module, otherwise we get different variable names
pkg_check_modules(OPTS_GTK
+ gio-2.0
gcr-3>=2.32
)
add_definitions("-DGCR_VERSION=\"${OPTS_GTK_gcr-3_VERSION}\"")
@@ -139,7 +142,7 @@ elseif (HALF_BRO_INCOM_WEBKIT2)
set(EXTRA_VAPIS ${EXTRA_VAPIS} "${CMAKE_SOURCE_DIR}/midori/webkit2gtk-3.0.vapi")
# Always pass >1 module, otherwise we get different variable names
pkg_check_modules(OPTS_GTK
- gtk+-3.0>=3.0.0
+ gio-2.0
gcr-3>=2.32
)
add_definitions("-DGCR_VERSION=\"${OPTS_GTK_gcr-3_VERSION}\"")