summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8fe6551..d0ff6202 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,17 +187,16 @@ if (USE_ZEITGEIST)
set(PKGS ${PKGS} zeitgeist-1.0)
endif()
-if (USE_GTK3)
- pkg_check_modules(GCR gcr-3>=2.32)
- if (GCR_VERSION)
- set(OPTS_INCLUDE_DIRS "${OPTS_INCLUDE_DIRS};${GCR_INCLUDE_DIRS}")
- set(OPTS_LIBRARIES "${OPTS_LIBRARIES};${GCR_LIBRARIES}")
- add_definitions("-DGCR_VERSION=\"${GCR_VERSION}\"")
- add_definitions("-DHAVE_GCR")
- set(VALAFLAGS ${VALAFLAGS} -D HAVE_GCR)
+if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.34.0")
+ if (USE_GTK3)
+ pkg_check_modules(GCR REQUIRED gcr-3>=2.32)
else ()
- add_definitions("-DGCR_VERSION=\"No\"")
+ pkg_check_modules(GCR REQUIRED gcr-base-3>=2.32)
endif ()
+ add_definitions("-DGCR_VERSION=\"${GCR_VERSION}\"")
+ add_definitions("-DHAVE_GCR")
+ set(OPTS_INCLUDE_DIRS ${OPTS_INCLUDE_DIRS} ${GCR_INCLUDE_DIRS})
+ set(OPTS_LIBRARIES ${OPTS_LIBRARIES} ${GCR_LIBRARIES})
else ()
add_definitions("-DGCR_VERSION=\"No\"")
endif ()