summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-03-15 22:57:16 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-04-10 19:04:32 +0200
commit6dd77065c3beb4aa32218d76ba27efb83d507f42 (patch)
tree666970c77566128ec9330e324d9e695dae2c0aaf /Makefile.am
parent647f21332d37c05e888eb9d01261310450704d53 (diff)
downloadmobile-broadband-provider-info-6dd77065c3beb4aa32218d76ba27efb83d507f42.tar.gz
apn-conf: generate Android-compatible APN listlr/android-apn
Some distros (Ubuntu Touch) read out Android-style APN list. Generate one from our database so they can use it. https://gitlab.gnome.org/GNOME/mobile-broadband-provider-info/merge_requests/4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 646d47c..c023a6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,11 @@ EXTRA_DIST = mobile-broadband-provider-info.pc.in
pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = mobile-broadband-provider-info.pc
+apns-conf.xml: $(top_srcdir)/apns-conf.xsl $(top_srcdir)/$(SP_XML_DB)
+ $(AM_V_GEN) $(XSLTPROC) --output $@ $^
+
+pkgdata_DATA = apns-conf.xml
+
check-local:
xmllint --valid $(top_srcdir)/$(SP_XML_DB) 2>&1 > /dev/null || exit 1;