summaryrefslogtreecommitdiff
path: root/api/leveldb/Makefile.am
diff options
context:
space:
mode:
authorAlex Gorrod <alexg@wiredtiger.com>2014-06-13 15:24:01 +1000
committerAlex Gorrod <alexg@wiredtiger.com>2014-06-13 15:24:01 +1000
commit789b3ae862818f8a036072c21b7e557483fb271e (patch)
treeae16df935876f0168ecfa75b6a2ea59ca1ef9c46 /api/leveldb/Makefile.am
parent6a3b23796008effbbb28a9ec9b1939a097273508 (diff)
downloadmongo-789b3ae862818f8a036072c21b7e557483fb271e.tar.gz
Add in the a copy of the LevelDB header files, and use them in our LevelDB API.
This avoids us needing to maintain compatability with the numerous different versions of LevelDB in the wild. Header files will be installed to $include/wiredtiger/leveldb
Diffstat (limited to 'api/leveldb/Makefile.am')
-rw-r--r--api/leveldb/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/api/leveldb/Makefile.am b/api/leveldb/Makefile.am
index 740dfb16456..555a443da09 100644
--- a/api/leveldb/Makefile.am
+++ b/api/leveldb/Makefile.am
@@ -1,10 +1,28 @@
-AM_CPPFLAGS = -I$(top_builddir)
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/api/leveldb/include
lib_LTLIBRARIES = libwiredtiger_leveldb.la
LDADD = $(lib_LTLIBRARIES) $(top_builddir)/libwiredtiger.la
noinst_PROGRAMS = leveldb_test
+# Setup the LevelDB headers to be installed in a wiredtiger/leveldb
+# subdirectory, so we don't interfere with other LevelDB installs.
+leveldbincludedir = $(includedir)/wiredtiger/leveldb
+leveldbinclude_HEADERS = \
+ include/cache.h \
+ include/c.h \
+ include/comparator.h\
+ include/db.h \
+ include/env.h \
+ include/filter_policy.h \
+ include/iterator.h \
+ include/options.h \
+ include/slice.h \
+ include/status.h \
+ include/table_builder.h \
+ include/table.h \
+ include/write_batch.h
+
libwiredtiger_leveldb_la_LDFLAGS = -release @VERSION@
libwiredtiger_leveldb_la_SOURCES = \
leveldb_wt.cc \