summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorkristina <k@wooster.(none)>2009-05-27 10:06:07 -0400
committerkristina <k@wooster.(none)>2009-05-27 10:06:07 -0400
commitedee72dc444aa54c65e72bb8bd96f8864b8179c1 (patch)
treef8e86a43ab98d880803024ff9be61eb7676c9868 /debian/rules
parentb8c6d85506d04c3b9d9b804fcf6d1e763b55f963 (diff)
downloadmongo-edee72dc444aa54c65e72bb8bd96f8864b8179c1.tar.gz
debian build
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules95
1 files changed, 95 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000000..9380efe7067
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,95 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ scons --distname=deb --nojni
+ #docbook-to-man debian/mongodb.sgml > mongodb.1
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ scons -c
+ rm -f config.log
+ rm -f mongo
+ rm -f mongod
+ rm -f mongoimportjson
+ rm -f mongoexport
+ rm -f mongorestore
+ rm -f mongodump
+ rm -f mongofiles
+ rm -f .sconsign.dblite
+ rm -f libmongoclient.a
+ rm -rf client/*.o
+ rm -rf tools/*.o
+ rm -rf shell/*.o
+ rm -rf .sconf_temp
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ scons --prefix=$(CURDIR)/debian/mongodb install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+ dh_installinit
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure