summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorErnie Hershey <ernie.hershey@10gen.com>2013-09-26 18:06:20 -0400
committerErnie Hershey <ernie.hershey@10gen.com>2013-10-04 13:25:27 -0400
commit09ffdcc9274e20b879710cdb5d1271a65e6c6470 (patch)
treea32fb276bca972847b541998e37a9a6ca2d4b9d6 /debian
parent060a5527947a4facdacfb15cbbfa18d75dbfdb19 (diff)
downloadmongo-09ffdcc9274e20b879710cdb5d1271a65e6c6470.tar.gz
SERVER-10871 Change 'mongodb' to 'mongo' to mean the mongod process and service
Diffstat (limited to 'debian')
-rw-r--r--debian/init.d6
-rw-r--r--debian/mongod.upstart (renamed from debian/mongodb.upstart)6
-rw-r--r--debian/rules2
3 files changed, 7 insertions, 7 deletions
diff --git a/debian/init.d b/debian/init.d
index 85aa24e84a7..013fca55545 100644
--- a/debian/init.d
+++ b/debian/init.d
@@ -20,7 +20,7 @@
# Suite 330, Boston, MA 02111-1307 USA
#
### BEGIN INIT INFO
-# Provides: mongodb
+# Provides: mongod
# Required-Start: $network $local_fs $remote_fs
# Required-Stop: $network $local_fs $remote_fs
# Should-Start: $named
@@ -50,7 +50,7 @@ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/bin/mongod
DESC=database
-NAME=mongodb
+NAME=mongod
# Defaults. Can be overridden by the /etc/default/$NAME
# Other configuration options are located in $CONF file. See here for more:
# http://dochub.mongodb.org/core/configurationoptions
@@ -80,7 +80,7 @@ if test ! -x $DAEMON; then
exit 0
fi
-if test "x$ENABLE_MONGODB" != "xyes"; then
+if test "x$ENABLE_MONGOD" != "xyes"; then
exit 0
fi
diff --git a/debian/mongodb.upstart b/debian/mongod.upstart
index 9a3b50835af..48180ba8a4e 100644
--- a/debian/mongodb.upstart
+++ b/debian/mongod.upstart
@@ -13,7 +13,7 @@ start on runlevel [2345]
stop on runlevel [06]
script
- ENABLE_MONGODB="yes"
- if [ -f /etc/default/mongodb ]; then . /etc/default/mongodb; fi
- if [ "x$ENABLE_MONGODB" = "xyes" ]; then exec start-stop-daemon --start --quiet --chuid mongodb --exec /usr/bin/mongod -- --config /etc/mongod.conf; fi
+ ENABLE_MONGOD="yes"
+ if [ -f /etc/default/mongod ]; then . /etc/default/mongod; fi
+ if [ "x$ENABLE_MONGOD" = "xyes" ]; then exec start-stop-daemon --start --quiet --chuid mongodb --exec /usr/bin/mongod -- --config /etc/mongod.conf; fi
end script
diff --git a/debian/rules b/debian/rules
index ee0ec73414c..7ba9651507a 100644
--- a/debian/rules
+++ b/debian/rules
@@ -137,7 +137,7 @@ binary-arch: build install
# dh_installemacsen
# dh_installpam
# dh_installmime
- dh_installinit -pmongodb-org-unstable-server --name=mongodb
+ dh_installinit -pmongodb-org-unstable-server --name=mongod
# dh_installinfo
dh_installman
dh_link