summaryrefslogtreecommitdiff
path: root/lang/python/setup.py
diff options
context:
space:
mode:
authorMichael Cahill <michael.cahill@wiredtiger.com>2011-04-26 17:24:21 +1000
committerMichael Cahill <michael.cahill@wiredtiger.com>2011-04-26 17:24:21 +1000
commit3a6dc4749e89360db31553719e569fab8b2a40d7 (patch)
tree50c45b7441c091be7b78e07fdc7781d18beaa55b /lang/python/setup.py
parent7e20b189ca9e39df3250d6dc1f4f201560813321 (diff)
downloadmongo-3a6dc4749e89360db31553719e569fab8b2a40d7.tar.gz
Fix Python build again: split SWIG out of setup.py, we want to distribute the
results so SWIG isn't required by users to build the Python API. This also addresses some annoyances with paths, since we want to build in a different place from the Python sources.
Diffstat (limited to 'lang/python/setup.py')
-rw-r--r--lang/python/setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/python/setup.py b/lang/python/setup.py
index 557c5b4471a..d42063e3c3a 100644
--- a/lang/python/setup.py
+++ b/lang/python/setup.py
@@ -1,14 +1,15 @@
-import os, sys
+import os
from distutils.core import setup, Extension
# OS X hack: turn off the Universal binary support that is built into the
# Python build machinery, just build for the default CPU architecture.
if not 'ARCHFLAGS' in os.environ:
os.environ['ARCHFLAGS'] = ''
-dir = os.path.dirname(sys.argv[0])
+
+dir = os.path.dirname(__file__)
setup(name='wiredtiger', version='1.0',
- ext_modules=[Extension('_wiredtiger', [os.path.join(dir, 'wiredtiger.i')],
+ ext_modules=[Extension('_wiredtiger', ['wiredtiger_wrap.c'],
include_dirs=['.'],
library_dirs=['.'],
libraries=['wiredtiger'],