summaryrefslogtreecommitdiff
path: root/lang/python/setup.py
diff options
context:
space:
mode:
authorMichael Cahill <michael.cahill@wiredtiger.com>2011-04-26 17:34:23 +1000
committerMichael Cahill <michael.cahill@wiredtiger.com>2011-04-26 17:34:23 +1000
commitc0650abe866625d3b98bfa7be7fbade16e8fb7bb (patch)
tree6944a4dd20e85d1d7faa0d55cebc456c40400301 /lang/python/setup.py
parent3a6dc4749e89360db31553719e569fab8b2a40d7 (diff)
downloadmongo-c0650abe866625d3b98bfa7be7fbade16e8fb7bb.tar.gz
Another fix for relative paths in the Python build: setup.py wants to own the tree.
Diffstat (limited to 'lang/python/setup.py')
-rw-r--r--lang/python/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python/setup.py b/lang/python/setup.py
index d42063e3c3a..5786c404faa 100644
--- a/lang/python/setup.py
+++ b/lang/python/setup.py
@@ -9,7 +9,8 @@ if not 'ARCHFLAGS' in os.environ:
dir = os.path.dirname(__file__)
setup(name='wiredtiger', version='1.0',
- ext_modules=[Extension('_wiredtiger', ['wiredtiger_wrap.c'],
+ ext_modules=[Extension('_wiredtiger',
+ [os.path.join(dir, 'wiredtiger_wrap.c')],
include_dirs=['.'],
library_dirs=['.'],
libraries=['wiredtiger'],