summaryrefslogtreecommitdiff
path: root/rpm/mongo.mdv.spec
diff options
context:
space:
mode:
authorErnie Hershey <ernie.hershey@10gen.com>2014-03-17 18:09:24 -0400
committerErnie Hershey <ernie.hershey@10gen.com>2014-03-19 16:43:37 -0400
commitb77054ef247c2b6ac11780f0a8676ecd0b4c3151 (patch)
treeab7f0109d260a9b61eca670ad702bc93c7e51378 /rpm/mongo.mdv.spec
parent4a299302a7312cebb076d0b356c5235c2f45918c (diff)
downloadmongo-b77054ef247c2b6ac11780f0a8676ecd0b4c3151.tar.gz
SERVER-12095 Update project description in Linux packaging text
This change makes packaging text more consistent between rpms and debs, as well as bringing the text up to date with more recent verbiage.
Diffstat (limited to 'rpm/mongo.mdv.spec')
-rw-r--r--rpm/mongo.mdv.spec61
1 files changed, 48 insertions, 13 deletions
diff --git a/rpm/mongo.mdv.spec b/rpm/mongo.mdv.spec
index 5b500a190d6..8da26a33c7e 100644
--- a/rpm/mongo.mdv.spec
+++ b/rpm/mongo.mdv.spec
@@ -16,13 +16,23 @@ BuildRequires: js-devel, readline-devel, boost-devel, pcre-devel
BuildRequires: gcc-c++, scons
%description
-Mongo (from "huMONGOus") is a schema-free document-oriented database.
-It features dynamic profileable queries, full indexing, replication
-and fail-over support, efficient storage of large binary data objects,
-and auto-sharding.
+MongoDB is built for scalability, performance and high availability, scaling from single server deployments to large, complex multi-site architectures. By leveraging in-memory computing, MongoDB provides high performance for both reads and writes. MongoDB’s native replication and automated failover enable enterprise-grade reliability and operational flexibility.
+
+MongoDB is an open-source database used by companies of all sizes, across all industries and for a wide variety of applications. It is an agile database that allows schemas to change quickly as applications evolve, while still providing the functionality developers expect from traditional databases, such as secondary indexes, a full query language and strict consistency.
+
+MongoDB has a rich client ecosystem including hadoop integration, officially supported drivers for 10 programming languages and environments, as well as 40 drivers supported by the user community.
+
+MongoDB features:
+* JSON Data Model with Dynamic Schemas
+* Auto-Sharding for Horizontal Scalability
+* Built-In Replication for High Availability
+* Rich Secondary Indexes, including geospatial
+* TTL indexes
+* Text Search
+* Aggregation Framework & Native MapReduce
+
+This package contains the mongo shell, import/export tools, and other client utilities.
-This package provides the mongo shell, import/export tools, and other
-client utilities.
%package server
Summary: MongoDB server, sharding server, and support scripts
@@ -30,20 +40,45 @@ Group: Databases
Requires: mongodb
%description server
-Mongo (from "huMONGOus") is a schema-free document-oriented database.
+MongoDB is built for scalability, performance and high availability, scaling from single server deployments to large, complex multi-site architectures. By leveraging in-memory computing, MongoDB provides high performance for both reads and writes. MongoDB’s native replication and automated failover enable enterprise-grade reliability and operational flexibility.
+
+MongoDB is an open-source database used by companies of all sizes, across all industries and for a wide variety of applications. It is an agile database that allows schemas to change quickly as applications evolve, while still providing the functionality developers expect from traditional databases, such as secondary indexes, a full query language and strict consistency.
+
+MongoDB has a rich client ecosystem including hadoop integration, officially supported drivers for 10 programming languages and environments, as well as 40 drivers supported by the user community.
+
+MongoDB features:
+* JSON Data Model with Dynamic Schemas
+* Auto-Sharding for Horizontal Scalability
+* Built-In Replication for High Availability
+* Rich Secondary Indexes, including geospatial
+* TTL indexes
+* Text Search
+* Aggregation Framework & Native MapReduce
+
+This package contains the MongoDB server software, MongoDB sharded cluster query router, default configuration files, and init.d scripts.
-This package provides the mongo server software, mongo sharding server
-softwware, default configuration files, and init.d scripts.
%package devel
-Summary: Headers and libraries for mongo development.
+Summary: Headers and libraries for MongoDB development
Group: Databases
%description devel
-Mongo (from "huMONGOus") is a schema-free document-oriented database.
+MongoDB is built for scalability, performance and high availability, scaling from single server deployments to large, complex multi-site architectures. By leveraging in-memory computing, MongoDB provides high performance for both reads and writes. MongoDB’s native replication and automated failover enable enterprise-grade reliability and operational flexibility.
+
+MongoDB is an open-source database used by companies of all sizes, across all industries and for a wide variety of applications. It is an agile database that allows schemas to change quickly as applications evolve, while still providing the functionality developers expect from traditional databases, such as secondary indexes, a full query language and strict consistency.
+
+MongoDB has a rich client ecosystem including hadoop integration, officially supported drivers for 10 programming languages and environments, as well as 40 drivers supported by the user community.
+
+MongoDB features:
+* JSON Data Model with Dynamic Schemas
+* Auto-Sharding for Horizontal Scalability
+* Built-In Replication for High Availability
+* Rich Secondary Indexes, including geospatial
+* TTL indexes
+* Text Search
+* Aggregation Framework & Native MapReduce
-This package provides the mongo static library and header files needed
-to develop mongo client software.
+This package provides the MongoDB static library and header files needed to develop MongoDB client software.
%prep
%setup -n %{name}-src-r%{version}