summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/test/format/Makefile.am
diff options
context:
space:
mode:
authorRamon Fernandez <ramon@mongodb.com>2016-01-27 17:17:17 -0500
committerRamon Fernandez <ramon@mongodb.com>2016-01-27 17:17:21 -0500
commit90118b147a6943b19dc929862a11071538db1438 (patch)
treed1e2c409595332174953e7dbe2db262935d89ae5 /src/third_party/wiredtiger/test/format/Makefile.am
parentb8cad6a59cbce2831e69e6b94f9544d83d6e00b0 (diff)
downloadmongo-90118b147a6943b19dc929862a11071538db1438.tar.gz
Import wiredtiger-wiredtiger-2.7.0-505-g7fea169.tar.gz from wiredtiger branch mongodb-3.4
ref: 44463c5..7fea169 WT-2355 Fix minor scratch buffer usage in logging. WT-2348 xargs -P isn't portable WT-2347 Java: schema format edge cases WT-2344 OS X compiler warning WT-2342 Enhance wtperf to support background create and drop operations WT-2340 Add logging guarantee assertions, whitespace WT-2339 format post-rebalance verify failure (stress run #11586) WT-2338 Disable using pre-allocated log files when backup cursor is open WT-2335 NULL pointer crash in config_check_search with invalid configuration string WT-2333 Add a flag so drop doesn't block WT-2332 Bug in logging write-no-sync mode WT-2331 Checking of search() result for reference cursors before join() WT-2328 schema drop does direct unlink, it should use a block manager interface. WT-2326 Change WTPERF to use new memory allocation functions instead of the standard WT-2321 WT-2321: race between eviction and worker threads on the eviction queue WT-2320 Only check copyright when cutting releases WT-2316 stress test failure: WT_CURSOR.prev out-of-order returns WT-2314 page-swap error handling is inconsistent WT-2313 sweep-server: conn_dhandle.c, 610: dhandle != conn->cache->evict_file_next WT-2312 re-creating a deleted column-store page can corrupt the in-memory tree WT-2308 custom extractor for ref_cursors in join cursor WT-2305 Fix coverity scan issues on 23/12/2015 WT-2296 New log algorithm needs improving for sync/flush settings WT-2295 WT_SESSION.create does a full-scan of the main table WT-2287 WT_SESSION.rebalance WT-2275 broken DB after application crash WT-2267 Improve wtperf throttling implementation to provide steady load WT-2247 variable-length column-store in-memory page splits WT-2242 WiredTiger treats dead trees the same as other trees in eviction WT-2142 Connection cleanup in Python tests WT-2073 metadata cleanups WT-1801 Add a directory sync after rollback of a WT_SESSION::rename operation WT-1517 schema format edge cases SERVER-22064 Coverity analysis defect 77699: Unchecked return value SERVER-21619 sys-perf: WT crash during core_workloads_WT execution
Diffstat (limited to 'src/third_party/wiredtiger/test/format/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/test/format/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/third_party/wiredtiger/test/format/Makefile.am b/src/third_party/wiredtiger/test/format/Makefile.am
new file mode 100644
index 00000000000..8a2e2b49e4b
--- /dev/null
+++ b/src/third_party/wiredtiger/test/format/Makefile.am
@@ -0,0 +1,45 @@
+AM_CPPFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/src/include -I$(top_srcdir)/test/utility
+if HAVE_BERKELEY_DB
+AM_CPPFLAGS += -DHAVE_BERKELEY_DB \
+ -DBERKELEY_DB_PATH=\"$(BERKELEY_DB_PATH)\" -I$(BERKELEY_DB_PATH)/include
+endif
+
+noinst_PROGRAMS = t
+noinst_SCRIPTS = s_dumpcmp
+t_SOURCES =\
+ config.h format.h backup.c bulk.c compact.c config.c lrt.c ops.c \
+ rebalance.c salvage.c t.c util.c wts.c
+
+if HAVE_BERKELEY_DB
+t_SOURCES += bdb.c
+endif
+
+t_LDADD = $(top_builddir)/libwiredtiger.la
+if HAVE_BERKELEY_DB
+t_LDADD += -L$(BERKELEY_DB_PATH)/lib -ldb
+endif
+t_LDFLAGS = -static
+
+#noinst_LTLIBRARIES = lzo_compress.la
+
+# libtool hack: noinst_LTLIBRARIES turns off building shared libraries as well
+# as installation, it will only build static libraries. As far as I can tell,
+# the "approved" libtool way to turn them back on is by adding -rpath.
+#lzo_compress_la_SOURCES = lzo_compress.c
+#lzo_compress_la_LIBADD = -llzo2 -lm
+#lzo_compress_la_LDFLAGS = -avoid-version -module -rpath /nowhere
+
+s_dumpcmp: $(srcdir)/s_dumpcmp.sh
+ cp $(srcdir)/s_dumpcmp.sh $@
+ chmod +x $@
+
+backup:
+ rm -rf BACKUP && cp -p -r RUNDIR BACKUP
+refresh:
+ rm -rf RUNDIR && cp -p -r BACKUP RUNDIR
+
+TESTS = smoke.sh
+
+clean-local:
+ rm -rf RUNDIR s_dumpcmp *.core