summaryrefslogtreecommitdiff
path: root/test/checkpoint/Makefile.am
diff options
context:
space:
mode:
authorKeith Bostic <keith@wiredtiger.com>2012-06-18 19:39:49 +0000
committerKeith Bostic <keith@wiredtiger.com>2012-06-18 19:39:49 +0000
commit1ec35d2bfa9c0ac21b01d1932c90c75600b5ea13 (patch)
tree1144f71d08e2cfc7b1b1c72ecde77e0a3ffb1e22 /test/checkpoint/Makefile.am
parent13bd7f4b65b193ad92acf20eb18792704cb4fbcc (diff)
downloadmongo-1ec35d2bfa9c0ac21b01d1932c90c75600b5ea13.tar.gz
Get rid of "snapshot" at the API layer, drive the change down to the btree
handles; we'll get rid of "snapshot" in the rest of the system over time.
Diffstat (limited to 'test/checkpoint/Makefile.am')
-rw-r--r--test/checkpoint/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/checkpoint/Makefile.am b/test/checkpoint/Makefile.am
new file mode 100644
index 00000000000..655a9815180
--- /dev/null
+++ b/test/checkpoint/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)/src/include
+
+noinst_PROGRAMS = t
+t_SOURCES = checkpoint.c
+t_LDADD = $(top_builddir)/libwiredtiger.la
+t_LDFLAGS = -static
+
+# Run this during a "make check" smoke test.
+TESTS = $(noinst_PROGRAMS)
+
+clean-local:
+ rm -rf WiredTiger WiredTiger.* __* *.core