summaryrefslogtreecommitdiff
path: root/lang/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/Makefile.am')
-rw-r--r--lang/python/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/python/Makefile.am b/lang/python/Makefile.am
new file mode 100644
index 00000000000..1fd2c58b34d
--- /dev/null
+++ b/lang/python/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(abs_top_builddir)
+
+PYSRC = $(top_srcdir)/lang/python
+if DEBUG
+PY_SETUP_DEBUG = -g
+endif
+all-local: _wiredtiger.so
+$(PYSRC)/wiredtiger_wrap.c: $(top_builddir)/wiredtiger.h $(PYSRC)/wiredtiger.i
+ @(cd $(PYSRC) && $(SWIG) -python -I$(abs_top_builddir) wiredtiger.i)
+
+_wiredtiger.so: $(wt_LTLIBRARIES) $(PYSRC)/wiredtiger_wrap.c
+ $(PYTHON) $(PYSRC)/setup.py build_ext -b . -t . -f $(PY_SETUP_DEBUG)