summaryrefslogtreecommitdiff
path: root/lang/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/Makefile.am')
-rw-r--r--lang/python/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python/Makefile.am b/lang/python/Makefile.am
index 03c65a57028..b32d0321194 100644
--- a/lang/python/Makefile.am
+++ b/lang/python/Makefile.am
@@ -17,7 +17,8 @@ install-exec-local:
(cd $(PYSRC) && \
$(PYTHON) setup.py build_py -d $(abs_builddir)/build && \
$(PYTHON) setup.py build_ext -f -b $(abs_builddir)/build $(PYDIRS) && \
- $(PYTHON) setup.py install_lib -b $(abs_builddir)/build --skip-build $(PYTHON_INSTALL_ARG))
+ $(PYTHON) setup.py install_lib -b $(abs_builddir)/build --skip-build $(PYTHON_INSTALL_ARG) && \
+ rm -rf $(abs_builddir)/build)
# We build in different places for an install vs running from the tree:
# clean up both. Don't rely on "setup.py clean" -- everything that should