summaryrefslogtreecommitdiff
path: root/lang/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/Makefile.am')
-rw-r--r--lang/python/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/python/Makefile.am b/lang/python/Makefile.am
index fbc7d3b5835..fede28ff058 100644
--- a/lang/python/Makefile.am
+++ b/lang/python/Makefile.am
@@ -7,7 +7,7 @@ endif
all-local: _wiredtiger.so
$(PYSRC)/wiredtiger_wrap.c: $(top_srcdir)/src/include/wiredtiger.in $(PYSRC)/wiredtiger.i
@(cd $(PYSRC) && \
- $(SWIG) -python -threads -I$(abs_top_builddir) wiredtiger.i)
+ $(SWIG) -python -nodefaultctor -nodefaultdtor -threads -I$(abs_top_builddir) wiredtiger.i)
_wiredtiger.so: $(top_builddir)/libwiredtiger.la $(PYSRC)/wiredtiger_wrap.c
$(PYTHON) $(PYSRC)/setup.py build_ext -b . -t . -f $(PY_SETUP_DEBUG)