summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/examples/c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/wiredtiger/examples/c/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/examples/c/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/third_party/wiredtiger/examples/c/Makefile.am b/src/third_party/wiredtiger/examples/c/Makefile.am
new file mode 100644
index 00000000000..382c5912fef
--- /dev/null
+++ b/src/third_party/wiredtiger/examples/c/Makefile.am
@@ -0,0 +1,33 @@
+LDADD = $(top_builddir)/libwiredtiger.la
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+noinst_PROGRAMS = \
+ ex_access \
+ ex_all \
+ ex_async \
+ ex_backup \
+ ex_call_center \
+ ex_config \
+ ex_config_parse \
+ ex_cursor \
+ ex_data_source \
+ ex_extending \
+ ex_extractor \
+ ex_hello \
+ ex_log \
+ ex_pack \
+ ex_process \
+ ex_schema \
+ ex_scope \
+ ex_stat \
+ ex_thread
+
+# The examples can be run with no arguments as simple smoke tests
+TESTS = $(noinst_PROGRAMS)
+
+AM_TESTS_ENVIRONMENT = WIREDTIGER_HOME=`mktemp -d WT_HOME.XXXX` ; export WIREDTIGER_HOME ; rm -rf $$WIREDTIGER_HOME ; mkdir $$WIREDTIGER_HOME ;
+# automake 1.11 compatibility
+TESTS_ENVIRONMENT = $(AM_TESTS_ENVIRONMENT)
+
+clean-local:
+ rm -rf WT_HOME* *.core backup_full.* backup_incr.*