summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/ext/extractors/csv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/wiredtiger/ext/extractors/csv/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/ext/extractors/csv/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/third_party/wiredtiger/ext/extractors/csv/Makefile.am b/src/third_party/wiredtiger/ext/extractors/csv/Makefile.am
new file mode 100644
index 00000000000..bb2a35bbf8e
--- /dev/null
+++ b/src/third_party/wiredtiger/ext/extractors/csv/Makefile.am
@@ -0,0 +1,10 @@
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/src/include
+
+noinst_LTLIBRARIES = libwiredtiger_csv_extractor.la
+libwiredtiger_csv_extractor_la_SOURCES = csv_extractor.c
+
+# libtool hack: noinst_LTLIBRARIES turns off building shared libraries as well
+# as installation, it will only build static libraries. As far as I can tell,
+# the "approved" libtool way to turn them back on is by adding -rpath.
+libwiredtiger_csv_extractor_la_LDFLAGS = \
+ -avoid-version -module -rpath /nowhere