summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/test/csuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/wiredtiger/test/csuite/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/test/csuite/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/third_party/wiredtiger/test/csuite/Makefile.am b/src/third_party/wiredtiger/test/csuite/Makefile.am
index 8b29565b596..f737bc97bed 100644
--- a/src/third_party/wiredtiger/test/csuite/Makefile.am
+++ b/src/third_party/wiredtiger/test/csuite/Makefile.am
@@ -7,6 +7,9 @@ AM_LDFLAGS = -static
all_TESTS=
noinst_PROGRAMS=
+# The import test is only a shell script
+all_TESTS += import/smoke.sh
+
test_random_abort_SOURCES = random_abort/main.c
noinst_PROGRAMS += test_random_abort
all_TESTS += random_abort/smoke.sh
@@ -137,7 +140,7 @@ all_TESTS += test_wt4803_cache_overflow_abort
# Run this during a "make check" smoke test.
TESTS = $(all_TESTS)
-LOG_COMPILER = $(TEST_WRAPPER)
+LOG_COMPILER = env top_builddir=$(top_builddir) top_srcdir=$(top_srcdir) $(TEST_WRAPPER)
clean-local:
rm -rf WT_TEST.* core.* *.core