summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/test/format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/wiredtiger/test/format/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/test/format/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/third_party/wiredtiger/test/format/Makefile.am b/src/third_party/wiredtiger/test/format/Makefile.am
new file mode 100644
index 00000000000..8a2e2b49e4b
--- /dev/null
+++ b/src/third_party/wiredtiger/test/format/Makefile.am
@@ -0,0 +1,45 @@
+AM_CPPFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/src/include -I$(top_srcdir)/test/utility
+if HAVE_BERKELEY_DB
+AM_CPPFLAGS += -DHAVE_BERKELEY_DB \
+ -DBERKELEY_DB_PATH=\"$(BERKELEY_DB_PATH)\" -I$(BERKELEY_DB_PATH)/include
+endif
+
+noinst_PROGRAMS = t
+noinst_SCRIPTS = s_dumpcmp
+t_SOURCES =\
+ config.h format.h backup.c bulk.c compact.c config.c lrt.c ops.c \
+ rebalance.c salvage.c t.c util.c wts.c
+
+if HAVE_BERKELEY_DB
+t_SOURCES += bdb.c
+endif
+
+t_LDADD = $(top_builddir)/libwiredtiger.la
+if HAVE_BERKELEY_DB
+t_LDADD += -L$(BERKELEY_DB_PATH)/lib -ldb
+endif
+t_LDFLAGS = -static
+
+#noinst_LTLIBRARIES = lzo_compress.la
+
+# libtool hack: noinst_LTLIBRARIES turns off building shared libraries as well
+# as installation, it will only build static libraries. As far as I can tell,
+# the "approved" libtool way to turn them back on is by adding -rpath.
+#lzo_compress_la_SOURCES = lzo_compress.c
+#lzo_compress_la_LIBADD = -llzo2 -lm
+#lzo_compress_la_LDFLAGS = -avoid-version -module -rpath /nowhere
+
+s_dumpcmp: $(srcdir)/s_dumpcmp.sh
+ cp $(srcdir)/s_dumpcmp.sh $@
+ chmod +x $@
+
+backup:
+ rm -rf BACKUP && cp -p -r RUNDIR BACKUP
+refresh:
+ rm -rf RUNDIR && cp -p -r BACKUP RUNDIR
+
+TESTS = smoke.sh
+
+clean-local:
+ rm -rf RUNDIR s_dumpcmp *.core