summaryrefslogtreecommitdiff
path: root/src/third_party/wiredtiger/test/recovery/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/wiredtiger/test/recovery/Makefile.am')
-rw-r--r--src/third_party/wiredtiger/test/recovery/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/third_party/wiredtiger/test/recovery/Makefile.am b/src/third_party/wiredtiger/test/recovery/Makefile.am
new file mode 100644
index 00000000000..60f237dad10
--- /dev/null
+++ b/src/third_party/wiredtiger/test/recovery/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/test/utility
+
+noinst_PROGRAMS = t
+t_SOURCES = recovery.c
+t_LDADD = $(top_builddir)/libwiredtiger.la
+t_LDFLAGS = -static
+
+# Run this during a "make check" smoke test.
+TESTS = $(noinst_PROGRAMS)
+LOG_COMPILER = $(TEST_WRAPPER)
+
+clean-local:
+ rm -rf WiredTiger* *.core __*