summaryrefslogtreecommitdiff
path: root/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build')
-rw-r--r--src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build b/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build
new file mode 100644
index 00000000000..3f302538d8e
--- /dev/null
+++ b/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/gen_html/meson.build
@@ -0,0 +1,30 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+gen_html_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'lib'),
+ join_paths(zstd_rootdir, 'lib/common'),
+ join_paths(zstd_rootdir, 'contrib/gen_html'))
+
+gen_html = executable('gen_html',
+ join_paths(zstd_rootdir, 'contrib/gen_html/gen_html.cpp'),
+ include_directories: gen_html_includes,
+ native: true,
+ install: false)
+
+# Update zstd manual
+zstd_manual_html = custom_target('zstd_manual.html',
+ output : 'zstd_manual.html',
+ command : [gen_html,
+ zstd_version,
+ join_paths(meson.current_source_dir(), zstd_rootdir, 'lib/zstd.h'),
+ '@OUTPUT@'],
+ install : false)