summaryrefslogtreecommitdiff
path: root/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build')
-rw-r--r--src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build b/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build
new file mode 100644
index 00000000000..8f3822fd776
--- /dev/null
+++ b/src/third_party/zstandard-1.4.3/zstd/build/meson/contrib/pzstd/meson.build
@@ -0,0 +1,24 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+pzstd_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'contrib/pzstd'))
+pzstd_sources = [join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/main.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Options.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Pzstd.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/SkippableFrame.cpp')]
+pzstd = executable('pzstd',
+ pzstd_sources,
+ cpp_args: [ '-DNDEBUG', '-Wno-shadow', '-pedantic' ],
+ include_directories: pzstd_includes,
+ dependencies: [ libzstd_dep, thread_dep ],
+ install: true)