summaryrefslogtreecommitdiff
path: root/test/readonly/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/readonly/Makefile.am')
-rw-r--r--test/readonly/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/test/readonly/Makefile.am b/test/readonly/Makefile.am
new file mode 100644
index 00000000000..3abcd2386a1
--- /dev/null
+++ b/test/readonly/Makefile.am
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/test/utility
+
+noinst_PROGRAMS = t
+t_SOURCES = readonly.c
+t_LDADD = $(top_builddir)/libwiredtiger.la
+t_LDFLAGS = -static
+
+# Run this during a "make check" smoke test.
+TESTS = smoke.sh
+
+clean-local:
+ rm -rf WT_RD* WiredTiger* *.core __*