summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fcc86cd..c11c285 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,8 @@
## Makefile.am -- Process this file with automake to produce Makefile.in
+include_HEADERS = mpc.h
+
lib_LTLIBRARIES = libmpc.la
-libmpc_la_SOURCES = mpc.h mpc-impl.h abs.c add.c add_fr.c add_ui.c clear.c \
+libmpc_la_SOURCES = mpc-impl.h abs.c add.c add_fr.c add_ui.c clear.c \
cmp.c cmp_si_si.c conj.c div_2exp.c div.c div_fr.c div_ui.c exp.c \
get_prec2.c get_prec.c init2.c init3.c init.c inp_str.c mul_2exp.c mul.c \
mul_fr.c mul_i.c mul_si.c mul_ui.c neg.c norm.c out_str.c random2.c random.c \
@@ -9,10 +11,11 @@ set_ui_ui.c sin.c sqr.c sqrt.c sub.c sub_ui.c uceil_log2.c ui_div.c \
ui_ui_sub.c
LDADD = $(top_builddir)/libmpc.la
-INCLUDES = -I$(top_srcdir)
+check_INCLUDES = -I$(top_srcdir)
check_PROGRAMS = test tabs tdiv texp tmul tsin tsqr
TESTS = $(check_PROGRAMS)
+CLEANFILES = $(top_builddir)/mpc_test
info_TEXINFOS = mpc.texi