summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-08-05 10:24:16 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-08-05 10:24:16 +0000
commit2d25da5d49ad072534ea7a15c32b38af91038f53 (patch)
tree7a21d36585af37de78f7afbe53e18fc26bdef943 /Makefile.am
parente8421758c5e7cdfc1b9072dc70d0d040e3b99270 (diff)
downloadmpfr-2d25da5d49ad072534ea7a15c32b38af91038f53.tar.gz
Since GNU Automake 1.11 is available on too few platforms, removed its
requirement (reverted to 1.10 requirement: 1.10.1 was needed only for dist-lzma, which has been removed). Instead, added hardcoded dist-xz support (tested with both Automake 1.10.2 and Automake 1.11). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6356 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fff5eae5..d1baee200 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,3 +86,14 @@ dist-hook:
grep -q -e -dev $(srcdir)/VERSION || \
test "`sed -n 's/^[0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p' $(srcdir)/VERSION`" = \
"`sed -n 's/.*-version-info [0-9]*:\([0-9]*\):.*/\1/p' $(srcdir)/Makefile.am`"
+
+# The following needs to be removed once GNU Automake 1.11 support is added.
+DIST_ARCHIVES = $(distdir).tar.gz $(distdir).tar.bz2 $(distdir).tar.xz \
+ $(distdir).zip
+dist dist-all: distdir
+ tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
+ tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
+ tardir=$(distdir) && $(am__tar) | xz -c >$(distdir).tar.xz
+ -rm -f $(distdir).zip
+ zip -rq $(distdir).zip $(distdir)
+ $(am__remove_distdir)