summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorschevill <schevill@280ebfd0-de03-0410-8827-d642c229c3f4>2010-03-17 17:35:59 +0000
committerschevill <schevill@280ebfd0-de03-0410-8827-d642c229c3f4>2010-03-17 17:35:59 +0000
commitb229ea504fd997e4e431d6d3dec593027594cb49 (patch)
treee02ce5f69ab4ebcb7848abf3e4696733530b08d3 /Makefile.am
parent2e6b64a83afb287e09975db5a8820454d4a361a1 (diff)
downloadmpfr-b229ea504fd997e4e431d6d3dec593027594cb49.tar.gz
* Added function mpfr_ai. The implementation is the most naive: it evaluates
the series step by step until it can stop. A special strategy is used to detect possible problems when Ai(x) is very close to 0. * Updated algorithms.tex with the technical description of the implementation of mpfr_ai. * Added algorithm2e.sty and algorithm2e-compatibility.sty (necessary to compile algorithms.tex now). * Updated mpfr.texi to let it know this new function. * Added a basic test file for mpfr_ai. I will add other test cases later. * Added a small HOWTO to README.dev about how to add a new test file for new functions. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6723 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ae1e9915..c85ae7cc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,7 +55,7 @@ round_near_x.c constant.c abort_prec_max.c stack_interface.c lngamma.c \
zeta_ui.c set_d64.c get_d64.c jn.c yn.c rem1.c get_patches.c add_d.c \
sub_d.c d_sub.c mul_d.c div_d.c d_div.c li2.c rec_sqrt.c min_prec.c \
buildopt.c digamma.c bernoulli.c isregular.c set_flt.c get_flt.c \
-scale2.c set_z_exp.c
+scale2.c set_z_exp.c ai.c
libmpfr_la_LIBADD = @LIBOBJS@