summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-06-21 12:32:44 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-06-21 12:32:44 +0000
commit3699ab09f6b321a77f1060877c756012f40b9a70 (patch)
treea3ce1e2db2105d3c85b87459676b777ab7a833e7 /Makefile.am
parent9b215e96995e0ad5c2fea944a8b0c832340d74f0 (diff)
downloadmpfr-3699ab09f6b321a77f1060877c756012f40b9a70.tar.gz
[Makefile.am] Fixed dist-hook for -dev versions (I assumed that ||
and && were right associative, while they are left associative). Thanks to Laurent Rineau for noticing this problem. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6965 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 91196228c..0eef84551 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,13 +119,13 @@ tune:
# But if the VERSION file contains "-dev", this is not checked.
# Note: this is a heuristic, to detect some mistakes.
dist-hook:
- grep -q -e -dev $(srcdir)/VERSION || \
+ grep -q -e -dev $(srcdir)/VERSION || { \
mv=`sed -n "s/^\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\\\\\\.\2/p" $(srcdir)/VERSION` && \
pl=`sed -n "s/^$$mv\.\([0-9][0-9]*\).*/\1/p" $(srcdir)/VERSION` && \
printf "mv=%s / pl=%s\n" "$$mv" "$$pl" && \
vinfo=`sed -n "s/^# *$$mv\.x *\([0-9][0-9]*\):x:\([0-9][0-9]*\)/\1:$$pl:\2/p" $(srcdir)/Makefile.am` && \
printf "vinfo=%s\n" "$$vinfo" && \
- grep -q -e "-version-info $$vinfo$$" $(srcdir)/Makefile.am
+ grep -q -e "-version-info $$vinfo$$" $(srcdir)/Makefile.am; }
# The following needs to be removed once GNU Automake 1.11 support is added.
DIST_ARCHIVES = $(distdir).tar.gz $(distdir).tar.bz2 $(distdir).tar.xz \