summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-02-26 01:26:45 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2009-02-26 01:26:45 +0000
commit112d4f3474b8cb734598b276142e985cc4078a0f (patch)
treed251ca57f49660bb62616a96bc21d3c9034837a0 /Makefile.am
parent74052f54774acbef22c65ba233e6041a70ad0ff7 (diff)
downloadmpfr-112d4f3474b8cb734598b276142e985cc4078a0f.tar.gz
Makefile.am: do not check libtool -version-info value if the VERSION
file contains "-dev". git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6019 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e39bef266..11797da25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,8 +66,11 @@ tune:
$(MAKE) $(AM_MAKEFLAGS) libmpfr.la
# In a "make dist", check that libtool -version-info value is up-to-date.
+# But if the VERSION file contains "-dev", this is not checked.
# Note: this is a heuristic, to detect some mistakes.
dist-hook:
- grep -q "`sed -n 's/^\([0-9]*\.[0-9]*\).*/\1/p' VERSION`.x" $(srcdir)/Makefile.am
- test "`sed -n 's/^[0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p' VERSION`" = \
- "`sed -n 's/.*-version-info [0-9]*:\([0-9]*\):.*/\1/p' $(srcdir)/Makefile.am`"
+ grep -q -e -dev $(srcdir)/VERSION || \
+ grep -q "`sed -n 's/^\([0-9]*\.[0-9]*\).*/\1/p' $(srcdir)/VERSION`.x" $(srcdir)/Makefile.am
+ grep -q -e -dev $(srcdir)/VERSION || \
+ test "`sed -n 's/^[0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p' $(srcdir)/VERSION`" = \
+ "`sed -n 's/.*-version-info [0-9]*:\([0-9]*\):.*/\1/p' $(srcdir)/Makefile.am`"