summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-05-28 08:16:16 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-05-28 08:16:16 +0000
commitb8e54aeadf27173e189517889057a924c9b1331d (patch)
tree02f8528635e9a2a87a2c059c49ef3c429996f79a /Makefile.am
parent5d2bdf2596b112f1ddc817364fd8c3e9706375bd (diff)
downloadmpfr-b8e54aeadf27173e189517889057a924c9b1331d.tar.gz
[Makefile.am] Improved dist-hook rule.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@6883 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 19ef2349c..0275f162d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,10 +119,12 @@ tune:
# Note: this is a heuristic, to detect some mistakes.
dist-hook:
grep -q -e -dev $(srcdir)/VERSION || \
- grep -q "`sed -n 's/^\([0-9]*\.[0-9]*\).*/\1/p' $(srcdir)/VERSION`.x" $(srcdir)/Makefile.am
- grep -q -e -dev $(srcdir)/VERSION || \
- test "`sed -n 's/^[0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p' $(srcdir)/VERSION`" = \
- "`sed -n 's/.*-version-info [0-9]*:\([0-9]*\):.*/\1/p' $(srcdir)/Makefile.am`"
+ mv=`sed -n "s/^\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\\\\\\.\2/p" $(srcdir)/VERSION` && \
+ pl=`sed -n "s/^$$mv\.\([0-9][0-9]*\).*/\1/p" $(srcdir)/VERSION` && \
+ printf "mv=%s / pl=%s\n" "$$mv" "$$pl" && \
+ vinfo=`sed -n "s/^# *$$mv\.x *\([0-9][0-9]*\):x:\([0-9][0-9]*\)/\1:$$pl:\2/p" $(srcdir)/Makefile.am` && \
+ printf "vinfo=%s\n" "$$vinfo" && \
+ grep -q -e "-version-info $$vinfo$$" $(srcdir)/Makefile.am
# The following needs to be removed once GNU Automake 1.11 support is added.
DIST_ARCHIVES = $(distdir).tar.gz $(distdir).tar.bz2 $(distdir).tar.xz \