summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-02-24 15:22:37 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-02-24 15:22:37 +0000
commit293686349e846576ae530643f96c7b2ccd1717f3 (patch)
tree01ff40b3bebee967d252f4e08f26d4744e1a00e4 /configure.ac
parent5b93d97aa3050d44cb010e34b09717b02a47741b (diff)
downloadmpfr-293686349e846576ae530643f96c7b2ccd1717f3.tar.gz
[configure.ac] Try to link with GMP even when a DLL, since it seems
to work now: https://sympa.inria.fr/sympa/arc/mpfr/2013-05/msg00010.html https://sympa.inria.fr/sympa/arc/mpfr/2015-12/msg00037.html Thus gmp_printf features (from the printf C function) are now tested, avoiding failures in the tests with thread-safe shared Windows builds using MinGW. (merged changeset r8524 from the trunk) git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/branches/3.1@10116 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 285b7816a..f3606722e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -402,7 +402,6 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
dnl Configs for Windows DLLs.
dnl libtool requires "-no-undefined" for win32 dll
-dnl It also disables the tests involving the linking with LIBGMP if DLL
dnl
dnl "-Wl,output-def" is used to get a .def file for use by MS lib to make
dnl a .lib import library, described in the manual.
@@ -419,7 +418,6 @@ case $host in
if test "$enable_shared" = yes; then
MPFR_LDFLAGS="$MPFR_LDFLAGS -no-undefined"
LIBMPFR_LDFLAGS="$LIBMPFR_LDFLAGS -Wl,--output-def,.libs/libmpfr-4.dll.def"
- dont_link_with_gmp="yes"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include "gmp.h"
#if !__GMP_LIBGMP_DLL
@@ -530,15 +528,6 @@ See 'config.log' for details (search for GMP_NUMB_BITS).])],
[AC_MSG_RESULT([cannot test])])
-dnl We really need to link using libtool. But it is impossible with the current
-dnl libtool.
-dnl The practical problems appear only under MS Windows since the library name
-dnl is libgmp-3 (due to libtool versionning). The best solution
-dnl is to believe it works under MS-Windows.
-if test "$dont_link_with_gmp" = yes ; then
-LIBS="-lgmp $LIBS"
-else
-
dnl Check if we can link with GMP
AC_CHECK_LIB(gmp, __gmpz_init, [LIBS="-lgmp $LIBS"],
[AC_MSG_ERROR(libgmp not found or uses a different ABI (including static vs shared).
@@ -609,9 +598,6 @@ dnl (see above).
dnl Same for __gmpn_sbpi1_divappr_q.
AC_CHECK_FUNCS([__gmpn_rootrem __gmpn_sbpi1_divappr_q])
-dnl End of tests which need to link with GMP.
-fi
-
dnl Remove also many MACROS (AC_DEFINE) which are unused by MPFR
dnl and polluate (and slow down because libtool has to parse them) the build.
if test -f confdefs.h; then