summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2015-05-20 12:52:26 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2015-05-20 12:52:26 +0000
commit58092473aedf4ba8450cb6efe1f6a40d9b04c0e5 (patch)
tree686c7aae3e1b751d0bd18c2850d68a3a6bceb5d7 /configure.ac
parent91f98079b0950c2dc1fab77bce28631901c63a7f (diff)
downloadmpfr-58092473aedf4ba8450cb6efe1f6a40d9b04c0e5.tar.gz
[acinclude.m4,configure.ac]
* Added test for double-to-integer conversion bug. * Corrected a gmp.h inclusion. * Added MPFR_CHECK_GMP configure check. Without this test, one could get an error in MPFR_CHECK_PRINTF_SPEC (or MPFR_CHECK_DBL2INT_BUG, taking into account the above addition), though the error is not related to printf or a double-to-integer conversion bug. (merged changesets r8353-8355,8432,8601-8602,8606,8614,8900 from the trunk) git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/branches/3.1@9412 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 335feb145..69efc6e41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,6 +498,8 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[
return (strcmp (buffer, gmp_version) != 0) ? 1 : 0;
]])],
[AC_MSG_RESULT(yes)
+ MPFR_CHECK_GMP
+ MPFR_CHECK_DBL2INT_BUG
MPFR_CHECK_PRINTF_SPEC],
[AC_MSG_RESULT(no)
AC_MSG_WARN([==========================================================])