summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2015-11-06 23:17:31 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2015-11-06 23:17:31 +0000
commitd5c85705444040cf9153084270b4b351790df2d4 (patch)
tree140822d228ba3700a2123ccef295a5ed9eabed33 /configure.ac
parent82c582ef8ec0cdf2029658dc0bc67aead6ca3765 (diff)
downloadmpfr-d5c85705444040cf9153084270b4b351790df2d4.tar.gz
GMP 5.0.0 or newer is required (instead of 4.2.0).
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@9731 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0bf46dad9..54f652ea2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -535,20 +535,20 @@ if test -z "$enable_mini_gmp" ; then
AC_MSG_CHECKING(for recent GMP)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include "gmp.h"
-#if (__GNU_MP_VERSION*100+__GNU_MP_VERSION_MINOR*10 < 420)
-# error "min GMP version is 4.2.0"
+#if (__GNU_MP_VERSION*100+__GNU_MP_VERSION_MINOR*10 < 500)
+# error "GMP 5.0.0 or newer is required"
error
#endif
]])],[AC_MSG_RESULT(yes)],[
AC_MSG_RESULT(no)
- AC_MSG_ERROR([GMP 4.2.0 or newer is required])
+ AC_MSG_ERROR([GMP 5.0.0 or newer is required])
])
fi
dnl Check if gmp.h is usable at link time; this may detect errors such as
dnl with GMP 4.1, which uses "extern __inline__" unconditionally with all
dnl GCC versions, which breaks by default with GCC 5 (this problem with
-dnl GMP 4.1 is no longer possible as we now require GMP 4.2.0 or newer,
+dnl GMP 4.1 is no longer possible as we now require GMP 5.0.0 or newer,
dnl but the same kind of problem may occur in the future).
dnl Note: No linking is done against the GMP library at this time, as we
dnl do not use any GMP symbol. The goal of this test is to avoid obscure