summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2014-07-07 12:43:59 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2014-07-07 12:43:59 +0000
commit0042944a05c2bada008edd3f3bccecbedb98b746 (patch)
tree41407ff34314f00b2e51e7ed0d5cf4e110562f14 /configure.ac
parent8f2321df512efa7b6de2a71f6b48406053aa0671 (diff)
downloadmpfr-0042944a05c2bada008edd3f3bccecbedb98b746.tar.gz
Added debug of branch prediction / --enable-debug-prediction configure
option (patch from Patrick PĂ©lissier, with some changes). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@9141 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e98284cb..2a746ef8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -345,6 +345,21 @@ AC_ARG_ENABLE(mini-gmp,
*) AC_MSG_ERROR([bad value for --enable-mini-gmp: yes or no]) ;;
esac])
+AC_ARG_ENABLE(debug-prediction,
+ [ --enable-debug-prediction
+ [[for developers]] enable debug of branch prediction
+ (for x86 and x86-64 with GCC, static libs)],
+ [ case $enableval in
+ yes) if test "$enable_shared" != no; then
+ AC_MSG_ERROR([--enable-debug-prediction can only work in static mode (--disable-shared)])
+ fi
+ AC_DEFINE([MPFR_DEBUG_PREDICTION],1,
+ [Enable debug of branch prediction]) ;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value for --enable-debug-prediction: yes or no]) ;;
+ esac])
+
+
dnl Check if compiler is ICC, and if such a case, disable GCC
dnl And add some specific flags.
dnl Don't add Warnings Flags (Otherwise you'll get more than 20000 warnings).