summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2014-01-24 15:17:15 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2014-01-24 15:17:15 +0000
commit07844421e7e40479d7fa5ced5cf3c663c3161ea6 (patch)
treeb66bfe6917aa67d4b61c6826f90770ef763a4e17 /configure.ac
parent42d4be28354af8067a62154afa7a62f28824dbd2 (diff)
downloadmpfr-07844421e7e40479d7fa5ced5cf3c663c3161ea6.tar.gz
Added MPFR_CHECK_GMP configure check.
Useful if the user provides --with-gmp with a directory containing a GMP version that doesn't have the correct ABI: the previous tests won't trigger the error if the same GMP version with the right ABI is installed on the system, as this library is automatically selected by the linker, while the header (which depends on the ABI) of the --with-gmp include directory is used. Before this test, one was getting an error in MPFR_CHECK_DBL2INT_BUG, though the error is not related to a double-to-integer conversion bug. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8900 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 196fafd29..10710a16f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -564,6 +564,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[
return (strcmp (buffer, gmp_version) != 0) ? 1 : 0;
]])],
[AC_MSG_RESULT(yes)
+ MPFR_CHECK_GMP
MPFR_CHECK_DBL2INT_BUG
MPFR_CHECK_PRINTF_SPEC],
[AC_MSG_RESULT(no)