summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-11 01:58:44 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-11 01:58:44 +0000
commit7fe8d4ab549189dbab63abbedbc565aa4e3cb591 (patch)
tree0319b567bc99380a84de2812bc88540b6944d82e /configure.ac
parent8caebc0505d019620cd3e8fec6ca66b9e02c41cb (diff)
downloadmpfr-7fe8d4ab549189dbab63abbedbc565aa4e3cb591.tar.gz
[configure.ac] In the CC and CFLAGS setup from gmp.h, modified the
list of commands to select the C preprocessor since /lib/cpp isn't the best choice under Solaris. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8612 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 35af7c87f..07291c3dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,9 +196,16 @@ if test -z "$GMP_CC$GMP_CFLAGS" ; then
AC_MSG_CHECKING(for CC and CFLAGS in gmp.h)
GMP_CC=__GMP_CC
GMP_CFLAGS=__GMP_CFLAGS
- for cpp in /lib/cpp gcc cc c99
+ # /lib/cpp under Solaris doesn't support some environment variables
+ # used by GCC, such as C_INCLUDE_PATH. If the user has set up such
+ # environment variables, he probably wants to use them. So, let us
+ # prefer cpp and gcc to /lib/cpp.
+ for cpp in cpp gcc /lib/cpp cc c99
do
- test $cpp = /lib/cpp || cpp="$cpp -E"
+ case $cpp in
+ *cpp*) ;;
+ *) cpp="$cpp -E" ;;
+ esac
echo foo > conftest.c
if $cpp $CPPFLAGS conftest.c > /dev/null 2> /dev/null ; then
# Get CC