summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-12-12 09:55:44 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-12-12 09:55:44 +0000
commit0d7bf90e59110626e30b17e468d9d446100f5fe2 (patch)
tree1bf469b61063bed859ceeeaacef9b49239068712 /configure.ac
parentbf5a0c218825eb13287a7c3ed65df5bb47d2abf6 (diff)
downloadmpfr-0d7bf90e59110626e30b17e468d9d446100f5fe2.tar.gz
[configure.ac] Fixed two problems with --with-gmp-build:
* "grep -w" isn't POSIX (an error shouldn't matter with recent GMP versions, as CFLAGS and CC would then be retrieved from gmp.h). * "sed" was used instead of "$SED". git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@7286 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a91f2b60f..14806cf5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,9 @@ test_CFLAGS=${CFLAGS+set}
AC_CANONICAL_HOST
+AC_PROG_EGREP
+AC_PROG_SED
+
dnl To use a separate config header.
dnl There is still some problem with GMP's HAVE_CONFIG
dnl AC_CONFIG_HEADERS([mpfrconf.h:mpfrconf.in])
@@ -77,8 +80,8 @@ AC_ARG_WITH(gmp_build,
LDFLAGS="$LDFLAGS -L$withval -L$withval/.libs -L$withval/tune"
gmp_lib_path="$withval$PATH_SEPARATOR$withval/.libs$PATH_SEPARATOR$withval/tune"
if test -r $withval/Makefile ; then
- GMP_CFLAGS=`grep -w "CFLAGS =" $withval/Makefile | sed 's/CFLAGS = //'`
- GMP_CC=`grep -w "CC =" $withval/Makefile | sed 's/CC = //'`
+ GMP_CFLAGS=`$SED -n 's/^CFLAGS = //p' $withval/Makefile`
+ GMP_CC=`$SED -n 's/^CC = //p' $withval/Makefile`
fi
use_gmp_build=yes
else
@@ -152,9 +155,6 @@ dnl Check if user request its CC and CFLAGS
if test -n "$CFLAGS" || test -n "$CC" ; then
user_redefine_cc=yes
fi
-dnl Autoconf detection
-AC_PROG_EGREP
-AC_PROG_SED
dnl ********************************************************************
dnl Check for CC and CFLAGS in gmp.h