summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-22 01:58:23 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-07-22 01:58:23 +0000
commit46bd029a9601c9c2d2ad663c85af1df44aa684c1 (patch)
tree94a69b0333b23890e66dcd4d9730c9be5d9daeeb /configure.ac
parent26582d11a29a9f8ddda29a57806657c7a7efd506 (diff)
downloadmpfr-46bd029a9601c9c2d2ad663c85af1df44aa684c1.tar.gz
[configure.ac] Added -Wno-unused-local-typedefs flag to avoid spurious
"typedef 'MPFR_ASSERT_xxx' locally defined but not used" warnings due to the implementation of static assertions. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8618 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 614848583..9d342fd7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -345,8 +345,11 @@ error
dnl If compiler is gcc, then use some specific flags.
dnl But don't touch user other flags.
+dnl The -Wno-unused-local-typedefs flag is added to avoid spurious
+dnl "typedef 'MPFR_ASSERT_xxx' locally defined but not used" warnings
+dnl due to the implementation of static assertions.
if test "$test_CFLAGS" != set && test -n "$GCC"; then
- CFLAGS="-Wall -Wmissing-prototypes -Wpointer-arith $CFLAGS"
+ CFLAGS="-Wall -Wmissing-prototypes -Wpointer-arith -Wno-unused-local-typedefs $CFLAGS"
fi
AM_PROG_CC_C_O