summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-05-24 13:59:10 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2013-05-24 13:59:10 +0000
commit75578f20f90fbba8fbbfa93af4590400834e531b (patch)
tree0e8b80be6d92ca06a088151264d35a2659b7524b /configure.ac
parent2491387e43476213c2806136674658ec5543c911 (diff)
downloadmpfr-75578f20f90fbba8fbbfa93af4590400834e531b.tar.gz
[configure.ac] For ICC, changed the deprecated -mp option to the
equivalent one -mieee-fp; added a comment about that. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8529 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f8d767ab8..7a278db3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,6 +304,11 @@ dnl the GCC variable confuses libtool. See:
dnl http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=485421
dnl * If need be, the gcc predefined macros __GNUC_* can be disabled
dnl thanks to the -no-gcc option.
+dnl * Now use -mieee-fp instead of -mp (ICC 13 says: option '-mp' is
+dnl deprecated and will be removed in a future release.). According
+dnl to "icc -help", both options are equivalent; it also suggests
+dnl to use -fp-model <arg> instead of -mp, but what is <arg>? Anyway
+dnl -mieee-fp solves the tset_d failure due to a negative zero.
AC_MSG_CHECKING(for ICC)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#if !defined(__ICC)
@@ -312,7 +317,7 @@ error
#endif
]], [[]])],[
AC_MSG_RESULT(yes)
- CFLAGS="-fp_port -mp -wd1572 -wd265 -wd186 -wd239 $CFLAGS"
+ CFLAGS="-fp_port -mieee-fp -wd1572 -wd265 -wd186 -wd239 $CFLAGS"
],[AC_MSG_RESULT(no)])
dnl If compiler is gcc, then use some specific flags.