summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@280ebfd0-de03-0410-8827-d642c229c3f4>2012-09-03 20:21:12 +0000
committerzimmerma <zimmerma@280ebfd0-de03-0410-8827-d642c229c3f4>2012-09-03 20:21:12 +0000
commit7f468cb280a98e16fefcd2fcef84ac7f4f978802 (patch)
treeefc05d979b016b6425ada005b9153cce44ac7c3e /configure.ac
parenta413c9cd7a3a0a84e6fe0128c042a9ca38a5e9c4 (diff)
downloadmpfr-7f468cb280a98e16fefcd2fcef84ac7f4f978802.tar.gz
Now --enable-decimal-float does not require any more --with-gmp-build.
Still disabled by default: some more testing is needed before we can enable it by default (if _Decimal64 is supported). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8402 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index faef96253..08684290e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,19 +244,7 @@ AC_ARG_ENABLE(decimal-float,
[Build decimal float functions])
AC_MSG_CHECKING(if compiler knows _Decimal64)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[_Decimal64 x;]])],
- [AC_MSG_RESULT(yes)
- if test "$use_gmp_build" != yes ; then
- AC_MSG_ERROR([decimal float support requires --with-gmp-build])
- fi
- AC_MSG_CHECKING(if _GMP_IEEE_FLOATS is defined)
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
-#include "gmp.h"
-#include "gmp-impl.h"
-#ifndef _GMP_IEEE_FLOATS
-#error "_GMP_IEEE_FLOATS is not defined"
-#endif]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
- AC_MSG_ERROR([decimal float support requires _GMP_IEEE_FLOATS])])
- ],
+ [AC_MSG_RESULT(yes)],
[AC_MSG_ERROR([Compiler doesn't know _Decimal64; try GCC >= 4.2, configured with --enable-decimal-float]
)])
AC_MSG_CHECKING(decimal float format)