summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@280ebfd0-de03-0410-8827-d642c229c3f4>2014-01-16 22:03:01 +0000
committerzimmerma <zimmerma@280ebfd0-de03-0410-8827-d642c229c3f4>2014-01-16 22:03:01 +0000
commitb8ef4f9b79a2a989a601bf0fad918541aaada8cd (patch)
tree1c85f14570a6c8de41a2b15e4c17f716c8a89b5a /configure.ac
parentf56d3181a510273c1dadce640072ebdaff3a8e94 (diff)
downloadmpfr-b8ef4f9b79a2a989a601bf0fad918541aaada8cd.tar.gz
first step towards making MPFR compile with --enable-mini-gmp, so far make
succeeds and all tests compile, but many tests fail, will investigate later git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8753 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1a53460bd..9e4d2941b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,6 +320,17 @@ AC_ARG_ENABLE(float128,
*) AC_MSG_ERROR([bad value for --enable-float128: yes or no]) ;;
esac])
+test_libgmp=__gmpz_init
+
+AC_ARG_ENABLE(mini-gmp,
+ [--enable-mini-gmp build MPFR with mini-gmp [[default=no]]],
+ [ case $enableval in
+ yes) AC_DEFINE([WANT_MINI_GMP],1,[Use mini-gmp])
+ test_libgmp=mpz_init;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value for --enable-mini-gmp: yes or no]) ;;
+ esac])
+
dnl Check if compiler is ICC, and if such a case, disable GCC
dnl And add some specific flags.
dnl Don't add Warnings Flags (Otherwise you'll get more than 20000 warnings).
@@ -512,9 +523,8 @@ You probably need to change some of the GMP or MPFR compile options.])],
[AC_MSG_RESULT([can't test])])
fi
-
dnl Check if we can link with GMP
-AC_CHECK_LIB(gmp, __gmpz_init, [LIBS="-lgmp $LIBS"],
+AC_CHECK_LIB(gmp, $test_libgmp, [LIBS="-lgmp $LIBS"],
[AC_MSG_ERROR(libgmp not found or uses a different ABI (including static vs shared).
Please read the INSTALL file -- see "In case of problem".)])