summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-05-23 16:12:32 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2016-05-23 16:12:32 +0000
commit2107bfbc19c3ea9b60adf575eb528e4e236ca8fe (patch)
treeac02996fbc0d823e5535bf88e3a01ee8f9bfd8cd /configure.ac
parent3eb219a24f100bcd97e77c3be9a0b59f1ed211a2 (diff)
downloadmpfr-2107bfbc19c3ea9b60adf575eb528e4e236ca8fe.tar.gz
Added shared cache support (from a patch by Patrick PĂ©lissier).
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@10327 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8233d2bdb..665997a4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,17 @@ AC_ARG_ENABLE(thread-safe,
*) AC_MSG_ERROR([bad value for --enable-thread-safe: yes or no]) ;;
esac])
+AC_ARG_ENABLE(shared-cache,
+ [ --enable-shared-cache enable use of caches shared by all threads,
+ for all MPFR constants. It usually makes MPFR
+ dependent on PTHREAD [[default=no]]],
+ [ case $enableval in
+ yes) mpfr_want_shared_cache=yes
+ AC_DEFINE([WANT_SHARED_CACHE],1,[Want shared cache]) ;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value for --enable-shared-cache: yes or no]) ;;
+ esac])
+
AC_ARG_ENABLE(warnings,
[ --enable-warnings allow MPFR to output warnings to stderr [[default=no]]],
[ case $enableval in