summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2012-06-26 22:35:39 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2012-06-26 22:35:39 +0000
commit751e3b472553cc09b0ef481e493b9d33ee105461 (patch)
treee42789d4ffeb61e6d3c6152b441423ff2be2d1ee /configure.ac
parentdd6c7ccdda671496280c77368532b3b008eff80f (diff)
downloadmpfr-751e3b472553cc09b0ef481e493b9d33ee105461.tar.gz
Added configure option --enable-assert=none to avoid checking any
assertion (this is based on a patch by Patrick). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@8271 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d456a296b..c7afc0f88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,9 +109,10 @@ AC_ARG_ENABLE(assert,
[ --enable-assert enable ASSERT checking [[default=no]]],
[ case $enableval in
yes) AC_DEFINE([WANT_ASSERT],1,[Want assertion]) ;;
+ none) AC_DEFINE([WANT_ASSERT],-1,[Do no want any assertion]) ;;
no) ;;
full) AC_DEFINE([WANT_ASSERT],2,[Want assertion]) ;;
- *) AC_MSG_ERROR([bad value for --enable-assert: yes, no or full]) ;;
+ *) AC_MSG_ERROR([bad value for --enable-assert: yes, no, none or full]) ;;
esac])
AC_ARG_ENABLE(logging,
[ --enable-logging enable MPFR logging (the system must support it)